Function

Disclaimer

The information contained in this Rapid-Q source file and the information contained in these help files are distributed freely without charge and carry no warranty either express or implied.

Users are cautioned to use these routines at their own risk.

If you have any questions about this include file please forward it to the discussion forum.


CHANGE LOG
Date | Version | Contributor | Change
01/19/2005 | 1.0.0 | Noble Bell | Initial Release with the original 4 functions (Sleep, Copyfile, KillFile, and Beep)


User Contributions

If you are going to contribute to this file please keep everything in its current format and make sure that you update the change-log so that others will know what you are doing.

This package is for "kernel32.dll" routines.

This package includes the following files:

"kernel32.inc" - The include file, in Rapid-Q, for the functions used from the "kernel32.dll" Windows(tm) file.

"kernel32.chm" - The windows html help file. (Please update this using HTML Help from Microsoft(tm)

"*.htm" - The seperate html pages containing each function's information.


BEEP <frequency>, <duration>

Purpose:

This function will beep the internal computer speaker at a set frequency for a set amount of time.

Parameters:

<frequency> - Tone of the sound in hertz. Can range from 32 to 32,767.

<duration> - The length of the beep in milliseconds. 1000 milliseconds is equal to 1 second.

Return Values:


COPYFILE <existing file>,<new file>,<overwrite>

Purpose:

This function will take a complete filepath and filename and copy it to another location with the

same name or a different name. You can also overwrite an existing file.

Parameters:

<existing file> - The complete path and filename of the file you want to copy (Source).

<new file> - The complete path and filename of where you want to copy the file and the name.

<overwrite> - True if you want to overwrite, False if you don't want to overwrite.

Return Values:

Returns a value of 1 if successful

Returns a value of 0 if failed


KILLFILE <filename>

Purpose:

This function will take a complete filepath and filename as a string and will delete the file.

Parameters:

<filename> - This is a string variable that must include the complete file path and filename of the

file that you want to erase.

Return Values:

Returns a value of 0 if not successful

Returns a value of 1 if successful


SLEEP <length>

Purpose:

This function will take halt the computer for the specified length.

Parameters:

<length> - The length to wait in milliseconds. 1000 milliseconds is equal to 1 second.

Return Values: